I recently had this problem, and even after ensuring that the bindings for the website were linked to all unassigned addresses, I could still only connect via the loopback address, 127.0.0.1. The first troubleshooting step was to look at all listeners using:

netstat -an

I noticed I had an entry for port 80 for 127.0.0.1, but not for my actual IP address—nor for 0.0.0.0:80, which would be all IP addresses:

TCP 127.0.0.1:80 0.0.0.0:0 LISTENING

The next step was to look at the actual HTTP IP listeners. Because I only had an IP present for 127.0.0.1, I added a listener for my real IP address and performed an IIS reset. I then had a listener on 127.0.0.1 and my physical IP address, and I could connect to the server via the IP address.

C:\>netsh
netsh>http
netsh http>show iplisten

IP addresses present in the IP listen list:
-------------------------------------------

127.0.0.1

netsh http>add iplisten ipaddress=100.76.72.126

IP address successfully added

netsh http>show iplisten

IP addresses present in the IP listen list:
-------------------------------------------

127.0.0.1
100.76.72.126

netsh http>exit


C:\>iisreset

Attempting stop...
Internet services successfully stopped
Attempting start...
Internet services successfully restarted

C:\>netstat -an
 TCP 100.76.72.126:80 0.0.0.0:0 LISTENING
 TCP 127.0.0.1:80 0.0.0.0:0 LISTENING

Another approach would have been to remove the 127.0.0.1 listener so there were no explicit IP addresses configured for the HTTP, which would have meant it would have listened on all IP addresses (this would actually be my preferred approach):

C:\>netsh
netsh>http
netsh http>show iplisten

IP addresses present in the IP listen list:
-------------------------------------------

127.0.0.1
100.76.72.126

netsh http>remove iplisten ipaddress=127.0.0.1
The following command was not found: remove iplisten ipaddress=127.0.0.1.
netsh http>del iplisten ipaddress=127.0.0.1

IP address successfully deleted

netsh http>del iplisten ipaddress=100.76.72.126

IP address successfully deleted

netsh http>exit


C:\>iisreset